Degraded performance on AI features

Incident Report for Decisions

Resolved

This incident has been resolved.
Posted Dec 09, 2025 - 07:34 CET

Investigating

We’re seeing slowness in performance of AI-related actions (e.g., AI Minutes, Recaps, Agenda Builder, My Assistant). Microsoft has confirmed an outage on servers related to Azure OpenAI performance.

We are still investigating potential solutions or workarounds.
Posted Dec 08, 2025 - 12:38 CET
This incident affected: Decisions AI.